Problem with device identity

Mich_P
Posts: 7
Joined: 18 Jan 2024, 09:03

Problem with device identity

Post

I’m facing problems with my device identity. Trying to adapt my drive device to start with the VIK-NAMUR drive profile GSDM I always get device mismatch error from the controller and connection establishment is not successful. I adapted my DAP to Device-ID and Vendor-ID mentioned in the VIK-NAMUR GSDML but without success. Did I missed something?
olliew
Posts: 9
Joined: 07 Oct 2023, 18:13
Location: somewhere in Germany

Re: Problem with device identity

Post

Mich_P wrote: 12 Feb 2024, 09:56 I always get device mismatch error from the controller and connection establishment is not successful.
Maybe a mismatch in API number?
A wireshark inspection of the Connect Request and Connect Response should point to the exact subslot position of the mismatch.
Raik.Zachmann
PROFINET Expert
Posts: 12
Joined: 19 Sep 2023, 07:37

Re: Problem with device identity

Post

Mich_P wrote: 12 Feb 2024, 09:56 I’m facing problems with my device identity. Trying to adapt my drive device to start with the VIK-NAMUR drive profile GSDM I always get device mismatch error from the controller and connection establishment is not successful. I adapted my DAP to Device-ID and Vendor-ID mentioned in the VIK-NAMUR GSDML but without success. Did I missed something?
Have you checked whether you are using the correct device instance number?
Mich_P
Posts: 7
Joined: 18 Jan 2024, 09:03

Re: Problem with device identity

Post

Raik.Zachmann wrote: 14 Feb 2024, 08:29
Mich_P wrote: 12 Feb 2024, 09:56 I’m facing problems with my device identity. Trying to adapt my drive device to start with the VIK-NAMUR drive profile GSDM I always get device mismatch error from the controller and connection establishment is not successful. I adapted my DAP to Device-ID and Vendor-ID mentioned in the VIK-NAMUR GSDML but without success. Did I missed something?
Have you checked whether you are using the correct device instance number?
That‘s the solution! There is a mismatch with the device instance number. I used the recommended default value which is 1, but the VIK-NAMUR GSD requests 0 as device instance number (ObjectUUID_LocalIndex).
Thank You very much for your support!
Ask another Question